カテゴリー
jQuery 雑記

jQuery 1.x vs. jQuery 2.x

jQuery を始めて使う場合、jQuery 1.x と jQuery 2.x のどちらをダウンロードすれば良いか?という疑問があるのではないですか?

jQuery ダウンロードサイトを参考にすると、

jQuery 1.x の最新版は 1.11.2 (2015/1/2 現在) です。1.9.0 で大きな変更があり、バージョン 1.9 以前のjQuery をお使いでバージョンアップするには jQuery Migrate Plugin (jQuery 移行プラグイン)を使用することが推奨されています。

jQuery 2.x の最新版は 2.1.3 です。こちらバージョンは jQuery 1.x と同じAPIを提供しているが、IE6, 7, 8 をサポートしていない点が異なります。IE8以前のサポートを考慮する必要がある場合は jQuery 1.x を使用することが推奨されています。

ということで、初めてjQuery を導入される場合、IE8以前をサポートするかどうかです。

ちなみに、当サイトでは、以前にjQuery 1.11.0 へバージョンアップしてを使用しています。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください